Advertisement - Hide this advert





Author Topic: Anyone else had the same problem??  (Read 932 times)

0 Members and 1 Guest are viewing this topic.

Offline keepupwith

  • MICROgeek (<20 posts)
  • *
  • Posts: 8
  • Liked: 0
Anyone else had the same problem??
« on: February 25, 2011, 05:09:26 PM »
Hi All...had arthroscopy, LR, clearout and debridement a week ago. Up until about day three, apart from one 'hole' having bled a lot no problems. Now at rest my knee is fine bent a little or straight, but when I change position I get really bad pain behind the knee cap. It's like someone has their fist in there and is squeezing!! Has anyone else had a similar thing?? Saw the physio and she was happy with the movement, but not with the swelling and I see the consultant again on Thursday. I don't know if this is normal, or something I should be concerned about. Any advice would be welcome. Thanks Pam

Offline TwoBadKneesUSA

  • SuperKNEEgeek
  • *****
  • *
  • Posts: 3340
  • Liked: 0
  • No matter how bad it is, my dog still loves me!
Re: Anyone else had the same problem??
« Reply #1 on: February 25, 2011, 09:54:30 PM »
It's not unusual to have pain like that, you are not far out from surgery after all.  It may be related to the swelling. Did your PT have an opinion about the pain?  Check with the doc when you see him/her.  Ice and elevate as much as you can to get the swelling down.  Good luck.

Milly
'83 lt knee scope
'88 lt knee LR
'89 rt knee LR (6 mos. after left)
'05 rt knee scope (clean up)
7/5/07 - scope, LR left, right clean
3/19/08 - LR failed, Supartz failed
http://www.kneeguru.co.uk/KNEEtalk/index.php?topic=47974.0
8/21/08 - new OS apt
8/5/09 - TTT, LR, PFJR sched.

Offline keepupwith

  • MICROgeek (<20 posts)
  • *
  • Posts: 8
  • Liked: 0
Re: Anyone else had the same problem??
« Reply #2 on: March 18, 2011, 09:29:22 AM »
Thanks Milly..pleased to report that it has settled  :)

Offline TwoBadKneesUSA

  • SuperKNEEgeek
  • *****
  • *
  • Posts: 3340
  • Liked: 0
  • No matter how bad it is, my dog still loves me!
Re: Anyone else had the same problem??
« Reply #3 on: March 18, 2011, 04:46:26 PM »
 ;D ;D
'83 lt knee scope
'88 lt knee LR
'89 rt knee LR (6 mos. after left)
'05 rt knee scope (clean up)
7/5/07 - scope, LR left, right clean
3/19/08 - LR failed, Supartz failed
http://www.kneeguru.co.uk/KNEEtalk/index.php?topic=47974.0
8/21/08 - new OS apt
8/5/09 - TTT, LR, PFJR sched.















support